1 # Maintainer: Florian Pritz <bluewind@xinu.at>
3 pkgname=perl-config-simple
6 pkgdesc="Simple configuration file class to create and read config files"
8 license=(PerlArtistic GPL)
11 url="https://search.cpan.org/~sherzodr/Config-Simple"
12 source=("https://search.cpan.org/CPAN/authors/id/S/SH/SHERZODR/Config-Simple-${pkgver}.tar.gz")
13 md5sums=('96513b61c7db591339ce2577878a3b32')
16 export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
17 PERL_AUTOINSTALL=--skipdeps \
18 PERL_MM_OPT="INSTALLDIRS=vendor" \
19 PERL_MB_OPT="--installdirs vendor" \
20 MODULEBUILDRC=/dev/null
22 cd "${srcdir}/Config-Simple-${pkgver}"
23 /usr/bin/perl Makefile.PL
28 export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
29 cd "${srcdir}/Config-Simple-${pkgver}"
35 cd "${srcdir}/Config-Simple-${pkgver}"
36 make DESTDIR="$pkgdir" install
37 find "$pkgdir" -name .packlist -o -name perllocal.pod -delete