sbcl rebuild
[arch-packages.git] / perl-string-shellquote / trunk / PKGBUILD
blob42a397acda9a088e29006cbbc8daf856504e5d49
1 # Maintainer: Felix Yan <felixonmars@gmail.com>
2 # Contributor: kevin <kevin@archlinux.org>
4 pkgname=perl-string-shellquote
5 _realname=String-ShellQuote
6 pkgver=1.04
7 pkgrel=6
8 pkgdesc="Quote strings for passing through the shell"
9 arch=('any')
10 license=('GPL')
11 url="https://search.cpan.org/dist/${_realname}/"
12 depends=('perl')
13 replaces=('string-shellquote')
14 options=('!emptydirs')
15 source=("https://search.cpan.org/CPAN/authors/id/R/RO/ROSCH/$_realname-$pkgver.tar.gz")
16 md5sums=('da6329dc482b21adf5697cfbd2ac5412')
18 build() {
19   cd ${_realname}-${pkgver}
20   # install module in vendor directories.
21   perl Makefile.PL INSTALLDIRS=vendor
22   make
25 check() {
26   cd ${_realname}-${pkgver}
27   make test
30 package() {
31   cd ${_realname}-${pkgver}
32   make install DESTDIR="${pkgdir}"
34   # remove perllocal.pod and .packlist
35   find "${pkgdir}" -name perllocal.pod -delete
36   find "${pkgdir}" -name .packlist -delete