sbcl rebuild
[arch-packages.git] / tevent / trunk / PKGBUILD
blob1de906c1a09287183eb1426f63af4e70ea4d7d68
1 # Maintainer: Tobias Powalowski <tpowa@archlinux.org>
2 # Contributor: Christian Hesse <mail@eworm.de>
3 # Contributor: Marco A Rojas <marquicus at gmail dot com>
4 # Contributor: Ng Oon-Ee <ngoonee.talk@gmail.com>
5 # Contributor: Thomas Burdick <thomas.burdick@gmail.com>
7 pkgname=tevent
8 pkgver=0.13.0
9 pkgrel=1
10 epoch=1
11 pkgdesc='Event system based on the talloc memory management library'
12 url="https://tevent.samba.org/"
13 arch=('x86_64')
14 source=(https://samba.org/ftp/tevent/${pkgname}-${pkgver}.tar{.gz,.asc})
15 license=('GPL3')
16 depends=('talloc')
17 makedepends=('python' 'cmocka')
18 optdepends=('python: for python bindings')
19 provides=(libtevent.so)
20 validpgpkeys=('9147A339719518EE9011BCB54793916113084025') # Samba Library Distribution Key <samba-bugs@samba.org>
21 sha512sums=('7aa05c09e3c708769e31cda88b319cee3629c88c51bda559193a85d4ab32204a8b4ba11f142861dbca06b578bf54953f2aca1ad847e99995a4fc40bf08618a93'
22             'SKIP')
24 build() {
25   cd ${pkgname}-${pkgver}
26   ./configure \
27     --prefix=/usr \
28     --bundled-libraries=NONE \
29     --builtin-libraries=replace
30   make
33 package() {
34   cd ${pkgname}-${pkgver}
35   make DESTDIR="${pkgdir}" install
38 # vim: ts=2 sw=2 et: