1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
7 pkgdesc="Automatic archives creating and extracting library"
8 url="https://wiki.gnome.org/TingweiLan/GSoC2013Final"
11 depends=(glib2 libarchive gtk3)
12 makedepends=(git gobject-introspection gtk-doc vala meson)
13 provides=(libgnome-autoar{,-gtk}-${pkgver%%.*}.so)
15 _commit=5739d99e286922dda48d4c0ebe51849c04561303 # tags/0.4.3^0
16 source=("git+https://gitlab.gnome.org/GNOME/gnome-autoar.git#commit=$_commit")
21 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
29 arch-meson $pkgname build \
33 meson compile -C build
37 meson test -C build --print-errorlogs
41 meson install -C build --destdir "$pkgdir"