archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gthumb / trunk / PKGBUILD
blob8306225f856d597b33ee1040b0d52a3f738ee5b8
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
3 # Contributor: Tobias Kieslich <tobias@justdreams.de>
5 pkgname=gthumb
6 pkgver=3.12.2
7 pkgrel=1
8 pkgdesc="Image browser and viewer for the GNOME Desktop"
9 url="https://wiki.gnome.org/Apps/gthumb"
10 arch=(x86_64)
11 license=(GPL)
12 depends=(dconf librsvg clutter-gtk gst-plugins-base-libs gsettings-desktop-schemas libwebp
13          libsecret libsoup webkit2gtk json-glib gst-plugin-gtk libjxl libheif)
14 makedepends=(libchamplain exiv2 brasero libraw liboauth docbook-xsl yelp-tools meson git)
15 optdepends=('libraw: read RAW files'
16             'exiv2: metadata support'
17             'libchamplain: map viewer'
18             'brasero: burn discs'
19             'liboauth: web albums')
20 options=(debug)
21 _commit=3132c5f25ffe6f22314ab0fbfb08e63ba523afab  # tags/3.12.2^0
22 source=("git+https://gitlab.gnome.org/GNOME/gthumb.git#commit=$_commit")
23 sha256sums=('SKIP')
25 pkgver() {
26   cd gthumb
27   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
30 prepare() {
31   cd gthumb
34 build() {
35   arch-meson gthumb build -D libchamplain=true
36   meson compile -C build
39 check() {
40   meson test -C build --print-errorlogs
43 package() {
44   meson install -C build --destdir "$pkgdir"