archrelease: copy trunk to extra-x86_64
[arch-packages.git] / qt5-base / repos / extra-x86_64 / PKGBUILD
blobbdad5dbeebe512ab5327b611552c1ce2b7b9252a
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Andrea Scarpino <andrea@archlinux.org>
4 pkgbase=qt5-base
5 pkgname=(qt5-base qt5-xcb-private-headers)
6 _basever=5.15.5
7 pkgver=5.15.5+kde+r182
8 pkgrel=1
9 _commit=a001e58a3f33ba3f6d250e10646af56bf7b415f0
10 arch=('x86_64')
11 url='https://www.qt.io'
12 license=('GPL3' 'LGPL3' 'FDL' 'custom')
13 pkgdesc='A cross-platform application and UI framework'
14 depends=('libjpeg-turbo' 'xcb-util-keysyms' 'xcb-util-renderutil' 'libgl' 'fontconfig' 'xdg-utils'
15          'shared-mime-info' 'xcb-util-wm' 'libxrender' 'libxi' 'sqlite' 'xcb-util-image' 'mesa'
16          'tslib' 'libinput' 'libxkbcommon-x11' 'libproxy' 'libcups' 'double-conversion' 'md4c')
17 makedepends=('libfbclient' 'mariadb-libs' 'unixodbc' 'postgresql-libs' 'alsa-lib' 'gst-plugins-base-libs'
18              'gtk3' 'libpulse' 'cups' 'freetds' 'vulkan-headers' 'git')
19 optdepends=('qt5-svg: to use SVG icon themes'
20             'qt5-wayland: to run Qt applications in a Wayland session'
21             'qt5-translations: for some native UI translations'
22             'postgresql-libs: PostgreSQL driver'
23             'mariadb-libs: MariaDB driver'
24             'unixodbc: ODBC driver'
25             'libfbclient: Firebird/iBase driver'
26             'freetds: MS SQL driver'
27             'gtk3: GTK platform plugin'
28             'perl: for fixqt4headers and syncqt')
29 conflicts=('qtchooser')
30 groups=('qt' 'qt5')
31 _pkgfqn=${pkgbase/5-/}
32 source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit
33         qmake-cflags.patch
34         qmake-config.patch)
35 sha256sums=('SKIP'
36             '5411edbe215c24b30448fac69bd0ba7c882f545e8cf05027b2b6e2227abc5e78'
37             '4abc22150fa3e06b2fdcec32146abc9be4e316692aa4d5bd5aa53b4b726783fa')
38 options=(debug)
40 pkgver() {
41   cd $_pkgfqn
42   echo "$_basever+kde+r"`git rev-list --count v$_basever-lts-lgpl..$_commit`
45 prepare() {
46   cd ${_pkgfqn}
47   patch -p1 < ../qmake-cflags.patch # Use system CFLAGS in qmake
48   patch -p1 < ../qmake-config.patch # Don't strip binaries with qmake and use -ltcg, cf. QTBUG-73834
51 build() {
52   cd ${_pkgfqn}
54   ./configure -confirm-license -opensource -v \
55     -prefix /usr \
56     -docdir /usr/share/doc/qt \
57     -headerdir /usr/include/qt \
58     -archdatadir /usr/lib/qt \
59     -datadir /usr/share/qt \
60     -sysconfdir /etc/xdg \
61     -examplesdir /usr/share/doc/qt/examples \
62     -plugin-sql-{psql,mysql,sqlite,odbc,ibase} \
63     -system-sqlite \
64     -openssl-linked \
65     -nomake examples \
66     -no-rpath \
67     -dbus-linked \
68     -system-harfbuzz \
69     -journald \
70     -no-mimetype-database \
71     -no-use-gold-linker \
72     -no-reduce-relocations \
73     -no-strip \
74     -ltcg
75 # No configure flag for fat static libs with lto
76   bin/qmake CONFIG+=fat-static-lto -- -redo
77   make
80 package_qt5-base() {
81   pkgdesc='A cross-platform application and UI framework'
82   depends+=(qt5-translations)
84   cd ${_pkgfqn}
85   make INSTALL_ROOT="${pkgdir}" install
87   install -Dm644 LICENSE* -t "$pkgdir"/usr/share/licenses/$pkgbase
89   # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
90   find "${pkgdir}/usr/lib" -type f -name '*.prl' \
91     -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
93   # Fix wrong qmake path in pri file
94   sed -i "s|${srcdir}/${_pkgfqn}|/usr|" \
95     "${pkgdir}"/usr/lib/qt/mkspecs/modules/qt_lib_bootstrap_private.pri
97   # Symlinks for backwards compatibility
98   for b in "${pkgdir}"/usr/bin/*; do
99     ln -s $(basename $b) "${pkgdir}"/usr/bin/$(basename $b)-qt5
100   done
103 package_qt5-xcb-private-headers() {
104   pkgdesc='Private headers for Qt5 Xcb'
106   depends=("qt5-base=$pkgver")
107   optdepends=()
108   groups=()
109   conflicts=()
111   cd ${_pkgfqn}
112   install -d -m755 "$pkgdir"/usr/include/qtxcb-private
113   cp -r src/plugins/platforms/xcb/*.h "$pkgdir"/usr/include/qtxcb-private/