db-move: moved gnome-font-viewer from [testing] to [extra] (x86_64)
[arch-packages.git] / giflib / trunk / PKGBUILD
blobcce656374d3319b783734ba7a516ad6ee1eec5fe
1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
2 # Maintainer: Jan de Groot <jgc@archlinux.org>
3 # Contributor: Baptiste Daroussin <baptiste.daroussin@gmail.com>
4 # Contributor: Grigorios Bouzakis <grbzks[at]gmail[dot]com>
5 # Contributor: mightyjaym <jm.ambrosino@free.fr>
7 pkgname=giflib
8 pkgver=5.2.1
9 pkgrel=2
10 pkgdesc='Library for reading and writing gif images'
11 url='http://giflib.sourceforge.net/'
12 arch=('x86_64')
13 license=('MIT')
14 depends=('glibc')
15 provides=('libgif.so')
16 makedepends=('xmlto' 'docbook-xml' 'docbook-xsl')
17 source=(https://downloads.sourceforge.net/project/giflib/${pkgname}-${pkgver}.tar.gz
18         giflib-5.1.9-fix-missing-quantize-API-symbols.patch
19         giflib-5.1.9-make-flags.patch)
20 sha512sums=('4550e53c21cb1191a4581e363fc9d0610da53f7898ca8320f0d3ef6711e76bdda2609c2df15dc94c45e28bff8de441f1227ec2da7ea827cb3c0405af4faa4736'
21             '5de1e8724f5221fa3637b4e6a482f650f7608673e2c9200233290018ec8a0bf1beea049b3979b5f57dbf2b2a5fda409324e636e9af10582fd01c71d92d4de3b3'
22             'b9afd436c31b971087485c7b476f796817e6ee4f237ef8a0e61e47f8ac59fbe5e673d7194895fcc9aafbb79f133469d27c2f69041ae0cccd9acb78667c0222dd')
24 prepare() {
25   cd ${pkgname}-${pkgver}
26   patch -Np1 < ../giflib-5.1.9-fix-missing-quantize-API-symbols.patch
27   patch -Np1 < ../giflib-5.1.9-make-flags.patch
30 build() {
31   cd ${pkgname}-${pkgver}
32   make
35 check() {
36   cd ${pkgname}-${pkgver}
37   make check
40 package() {
41   cd ${pkgname}-${pkgver}
42   make PREFIX=/usr DESTDIR="${pkgdir}" install
43   install -Dm 644 COPYING -t "${pkgdir}/usr/share/licenses/${pkgname}"
46 # vim: ts=2 sw=2 et: