db-move: moved gnome-font-viewer from [testing] to [extra] (x86_64)
[arch-packages.git] / libgxps / trunk / PKGBUILD
blob3973aad1b353172449f9c7dab6371b4b946fedec
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Maintainer: Jan de Groot <jgc@archlinux.org>
3 # Contributor: Ionut Biru <ibiru@archlinux.org>
5 pkgname=libgxps
6 pkgver=0.3.2
7 pkgrel=4
8 pkgdesc="XPS Documents library"
9 url="https://wiki.gnome.org/Projects/libgxps"
10 arch=(x86_64)
11 license=(GPL2)
12 depends=(
13   cairo
14   freetype2
15   glib2
16   lcms2
17   libarchive
18   libjpeg-turbo
19   libpng
20   libtiff
22 makedepends=(
23   git
24   gobject-introspection
25   gtk-doc
26   gtk3
27   meson
29 _commit=f5027ed09c767e8a02e652fbc77dcea79e19e10d  # tags/0.3.2^0
30 source=("git+https://gitlab.gnome.org/GNOME/libgxps.git#commit=$_commit")
31 b2sums=('SKIP')
33 pkgver() {
34   cd libgxps
35   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
38 prepare() {
39   cd libgxps
42 build() {
43   local meson_options=(
44     -D enable-man=true
45     -D enable-gtk-doc=true
46   )
48   arch-meson libgxps build "${meson_options[@]}"
49   meson compile -C build
52 check() {
53   meson test -C build --print-errorlogs
56 package() {
57   meson install -C build --destdir "$pkgdir"
60 # vim:set sw=2 sts=-1 et: