db-move: moved gnome-font-viewer from [testing] to [extra] (x86_64)
[arch-packages.git] / pytest-pacman / trunk / PKGBUILD
blobcc1d3b7a78e8cd3a32e5d6b413150c2476efe0c9
1 # Maintainer: Jelle van der Waa <jelle@archlinux.org>
3 pkgname=pytest-pacman
4 pkgver=0.1
5 pkgrel=4
6 pkgdesc="pacman db pytest fixture"
7 arch=('any')
8 license=('MIT')
9 url="https://gitlab.archlinux.org/archlinux/pytest-pacman"
10 depends=(python python-pytest python-setuptools)
11 makedepends=(git)
12 source=(git+https://gitlab.archlinux.org/archlinux/pytest-pacman.git?signed#tag=v${pkgver})
13 validpgpkeys=('E499C79F53C96A54E572FEE1C06086337C50773E')
14 sha512sums=('SKIP')
16 build() {
17   cd pytest-pacman
18   python setup.py build
21 package() {
22   cd pytest-pacman
24   python setup.py install --root="${pkgdir}" -O1 --skip-build
26   install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
27   install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"