db-move: moved gnome-font-viewer from [testing] to [extra] (x86_64)
[arch-packages.git] / qt6-translations / trunk / PKGBUILD
blob9082f59312c535c827a604641f7c54e945af0b65
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=qt6-translations
6 _qtver=6.5.0
7 pkgver=${_qtver/-/}
8 pkgrel=1
9 arch=(any)
10 url='https://www.qt.io'
11 license=(GPL3 LGPL3 FDL custom)
12 pkgdesc='A cross-platform application and UI framework (Translations)'
13 depends=()
14 makedepends=(cmake ninja qt6-tools)
15 groups=(qt6)
16 _pkgfn=${pkgname/6-/}-everywhere-src-$_qtver
17 source=(https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz)
18 sha256sums=('fc85d0fd8393f518653ccada1014177a56df6e73f30f3b64eea0c2e4a0067a3d')
20 build() {
21   export PATH="/usr/lib/qt6/bin:$PATH"
22   cmake -B build -S $_pkgfn -G Ninja \
23     -DCMAKE_MESSAGE_LOG_LEVEL=STATUS
24   cmake --build build -j1
27 package() {
28   DESTDIR="$pkgdir" cmake --install build
30   install -d "$pkgdir"/usr/share/licenses
31   ln -s /usr/share/licenses/qt6-base "$pkgdir"/usr/share/licenses/$pkgname