23.1.0-1
[arch-packages.git] / seed / trunk / PKGBUILD
blob73de3de0c5fb4777e49d858a4260e73b1cc6aa4e
1 #Maintainer : Ionut Biru <ibiru@archlinux.org>
2 #Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=seed
5 pkgver=3.8.1
6 pkgrel=4
7 pkgdesc="Library and interpreter for JavaScript with GObject type system bindings."
8 arch=('x86_64')
9 url="https://wiki.gnome.org/Projects/Seed"
10 license=('LGPL')
11 depends=('webkitgtk3' 'gobject-introspection-runtime' 'gnome-js-common' 'mpfr')
12 makedepends=('intltool' 'gobject-introspection')
13 source=(http://ftp.gnome.org/pub/GNOME/sources/${pkgname}/3.8/${pkgname}-${pkgver}.tar.xz
14         GLib.js rl63.patch)
15 sha256sums=('80cb4db7fa6f6cf8d3e255fc45a81657388d458bc8bf23e4089e35f69eeaac32'
16             '2a8185df661056e12830d0a29155dc539016fc349a823f5aec09dd15bbb9239b'
17             '8d91b5c46438350b139609e63f6f863fcd9949d631f87c3c4e267ad4987181a1')
19 prepare() {
20   cd "${srcdir}/${pkgname}-${pkgver}"
21   patch -p1 -i ../rl63.patch # Readline 6.3 compat (deprecated typedefs gone)
22   cp ../GLib.js extensions/
25 build() {
26   cd "${srcdir}/${pkgname}-${pkgver}"
27   ./configure --prefix=/usr --disable-static
28   make
31 package() {
32   cd "${srcdir}/${pkgname}-${pkgver}"
33   make DESTDIR="${pkgdir}" install