OCaml 4.13.1 rebuild, fixes FS#72998
[arch-packages.git] / libcloudproviders / trunk / PKGBUILD
blob31ae6d7589be0f7c82f78f51e6d9fac792f27f93
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Maxime Gauduin <alucryd@archlinux.org>
3 # Contributor: Fina Wilke <fina@felinira.net>
5 pkgname=libcloudproviders
6 pkgver=0.3.1
7 pkgrel=2
8 pkgdesc="DBus API that allows cloud storage sync clients to expose their services"
9 url="https://gitlab.gnome.org/World/libcloudproviders"
10 arch=(x86_64)
11 license=(LGPL3)
12 depends=(glib2)
13 makedepends=(git gobject-introspection meson vala gtk-doc)
14 _commit=4672d39320f4ef6091a4977b8e6a4ac079296c26  # tags/0.3.1^0
15 source=("git+https://gitlab.gnome.org/World/libcloudproviders.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd $pkgname
20   git describe --tags | sed 's/-/+/g'
23 prepare() {
24   cd $pkgname
27 build() {
28   arch-meson $pkgname build -D enable-gtk-doc=true
29   meson compile -C build
32 check() {
33   meson test -C build --print-errorlogs
36 package() {
37   DESTDIR="$pkgdir" meson install -C build