1 # Maintainer: Laurent Carlier <lordheavym@gmail.com>
6 pkgdesc="Library handling OpenGL function pointer management"
7 url="https://github.com/anholt/libepoxy"
11 makedepends=(python mesa-libgl git meson doxygen graphviz)
12 checkdepends=(xorg-server-xvfb)
13 _commit=ecfa8e0f083084181d36966fa084aca9a6c97d53 # tags/1.5.9^0
14 source=("git+https://github.com/anholt/libepoxy#commit=$_commit")
19 git describe --tags | sed 's/-/+/g'
27 arch-meson $pkgname build -D docs=true
28 meson compile -C build
32 xvfb-run -s '-nolisten local' \
33 meson test -C build --print-errorlogs
37 meson install -C build --destdir "$pkgdir"
38 install -Dm644 $pkgname/COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"