1 # Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
6 pkgdesc="Python bindings for systemd"
8 url="https://github.com/systemd/python-systemd"
10 depends=(python3 libsystemd)
11 makedepends=(systemd python git)
12 _commit=308ae4440c1f6ea1aff9be4cb683c52bd3a1c13a # tags/v234^0
13 source=("$pkgname::git+${url}#commit=$_commit")
18 git describe --tags | sed 's/^v//;s/-/+/g'
23 # reader: make PY_SSIZE_T_CLEAN
24 git format-patch -1 --stdout c71bbac357f0 | patch -Np1
29 make PYTHON=/usr/bin/python3
34 python3 setup.py install --root="$pkgdir" --optimize=1 --skip-build