OCaml 4.13.1 rebuild, fixes FS#72998
[arch-packages.git] / qt6-base / trunk / PKGBUILD
blob647eda60aa9660bf22657278c53ced3186a4bc22
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=qt6-base
6 _qtver=6.2.2
7 pkgver=${_qtver/-/}
8 pkgrel=1
9 arch=(x86_64)
10 url='https://www.qt.io'
11 license=(GPL3 LGPL3 FDL custom)
12 pkgdesc='A cross-platform application and UI framework'
13 depends=(libjpeg-turbo xcb-util-keysyms xcb-util-cursor libgl fontconfig xdg-utils
14          shared-mime-info xcb-util-wm libxrender libxi sqlite mesa vulkan-headers
15          tslib libinput libxkbcommon-x11 libproxy libcups double-conversion brotli libb2 md4c)
16 makedepends=(cmake ninja libfbclient mariadb-libs unixodbc postgresql alsa-lib gst-plugins-base-libs
17              gtk3 libpulse cups freetds xmlstarlet)
18 optdepends=('postgresql-libs: PostgreSQL driver'
19             'mariadb-libs: MariaDB driver'
20             'unixodbc: ODBC driver'
21             'libfbclient: Firebird/iBase driver'
22             'freetds: MS SQL driver'
23             'gtk3: GTK platform plugin'
24             'perl: for syncqt')
25 groups=(qt6)
26 _pkgfn="${pkgname/6-/}-everywhere-src-$_qtver"
27 source=(https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz
28         qt6-base-cflags.patch
29         qt6-base-nostrip.patch)
30 sha256sums=('85ab9180180c2eaf84cd11ae4c6d5a6a69f2f8fd7260aaccfd91a3e7e7232c1a'
31             'cf707cd970650f8b60f8897692b36708ded9ba116723ec8fcd885576783fe85c'
32             '4b93f6a79039e676a56f9d6990a324a64a36f143916065973ded89adc621e094')
34 prepare() {
35   patch -d $_pkgfn -p1 < qt6-base-cflags.patch # Use system CFLAGS
36   patch -d $_pkgfn -p1 < qt6-base-nostrip.patch # Don't strip binaries with qmake
39 build() {
40   cmake -B build -S $_pkgfn -G Ninja \
41     -DCMAKE_INSTALL_PREFIX=/usr \
42     -DINSTALL_BINDIR=lib/qt6/bin \
43     -DINSTALL_PUBLICBINDIR=usr/bin \
44     -DINSTALL_LIBEXECDIR=lib/qt6 \
45     -DINSTALL_DOCDIR=share/doc/qt6 \
46     -DINSTALL_ARCHDATADIR=lib/qt6 \
47     -DINSTALL_DATADIR=share/qt6 \
48     -DINSTALL_INCLUDEDIR=include/qt6 \
49     -DINSTALL_MKSPECSDIR=lib/qt6/mkspecs \
50     -DINSTALL_EXAMPLESDIR=share/doc/qt6/examples \
51     -DQT_FEATURE_journald=ON \
52     -DQT_FEATURE_openssl_linked=ON \
53     -DQT_FEATURE_system_sqlite=ON
54   cmake --build build
57 package() {
58   DESTDIR="$pkgdir" cmake --install build
60   install -Dm644 $_pkgfn/LICENSE* -t "$pkgdir"/usr/share/licenses/$pkgbase
62 # Install symlinks for user-facing tools
63   cd "$pkgdir"
64   mkdir usr/bin
65   while read _line; do
66     ln -s $_line
67   done < "$srcdir"/build/user_facing_tool_links.txt