1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
3 # Contributor: Aaron Griffin <aaron@archlinux.org>
4 # Original TU: Jeff Mickey <j@codemac.net>
5 # Contributor: ciccio.a
10 pkgdesc="Tools for squashfs, a highly compressed read-only filesystem for Linux."
11 url="https://github.com/plougher/squashfs-tools"
14 depends=('lz4' 'lzo' 'xz' 'zlib' 'zstd')
15 source=("https://github.com/plougher/squashfs-tools#tag=${pkgver/_/-}")
16 source=("${pkgname}-${pkgver}.tar.gz::https://github.com/plougher/${pkgname}/archive/refs/tags/${pkgver}.tar.gz"
17 "${pkgname}-4.5-symlink_install.patch")
18 sha512sums=('e00610487d24eed9e5dadcf84014a3d7faa9815d8ce00fd4660e6c8ce394dccf185ed9f387f4fa1313b9812fe770f802bdcbaef87887f2bcefacf234594a72e0'
19 'c2c77fb3741b75c2921ec6402d3532f87fd3d83e0e7042d88cf18835e30264547ce30b228bf5c0e5819075134871d27e2c8c5418257cbc66bfbfb730ef59a792')
20 b2sums=('2fc8ab9bb6565b97656afd63b76bfd7449d96b83697286e88b55a8cd82957b395df17a707ee93e8a99ed19dc5ba73966ce33530ef6c35797924dad4e3f16ed3b'
21 'd19e07109630eb10952630611a0ebdc1349585a89bed29341c9b7a623e7d165e3c047332396edd4ababe3516010289e2743e8dc09be733f464e216fffd09036e')
24 cd ${pkgname}-${pkgver}
25 # fix the creation of symlinks in install target
26 patch -Np1 -i "../${pkgname}-4.5-symlink_install.patch"
30 make -C ${pkgname}-${pkgver}/${pkgname} \
41 make -C ${pkgname}-${pkgver}/${pkgname} install INSTALL_DIR="${pkgdir}/usr/bin"