db-move: moved firefox-i18n from [testing] to [extra] (any)
[arch-packages.git] / gdl / trunk / PKGBUILD
blobdd249ca0d08c77e0e2a2c7ffc473addf8c7452b4
1 # Maintainer: Jan de Groot <jgc@archlinux.org>
3 pkgname=gdl
4 pkgver=3.40.0
5 pkgrel=1
6 pkgdesc="GNOME Docking Library"
7 url="https://gitlab.gnome.org/GNOME/gdl"
8 arch=(x86_64)
9 license=(GPL)
10 depends=(gtk3)
11 makedepends=(gtk-doc intltool gobject-introspection git)
12 _commit=bc1f6e9deba012fd81c6c378cd67942a955b0bee  # tags/GDL_3_40_0^0
13 source=("git+https://gitlab.gnome.org/GNOME/gdl.git#commit=$_commit")
14 sha256sums=('SKIP')
16 pkgver() {
17   cd $pkgname
18   git describe --tags | sed 's/^GDL_//;s/_/./g;s/-/+/g'
21 prepare() {
22   cd $pkgname
23   autoreconf -fvi
26 build() {
27   cd "$pkgname"
28   ./configure --prefix=/usr --sysconfdir=/etc \
29       --localstatedir=/var --disable-static --enable-gtk-doc
30   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
31   make
34 package() {
35   cd "$pkgname"
36   make DESTDIR="$pkgdir" install