archrelease: copy trunk to extra-x86_64
[arch-packages.git] / aisleriot / repos / extra-x86_64 / PKGBUILD
blob32f8ac7f27362e376bc48ab6acb99ed0527b7e64
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=aisleriot
4 pkgver=3.22.28
5 pkgrel=1
6 pkgdesc="A collection of patience games written in guile scheme"
7 url="https://wiki.gnome.org/Apps/Aisleriot"
8 arch=(x86_64)
9 license=(GPL)
10 depends=(
11   dconf
12   gtk3
13   guile
14   libcanberra
15   librsvg
17 makedepends=(
18   appstream-glib
19   git
20   meson
21   yelp-tools
23 optdepends=(
24   'pysolfc-cardsets: PySol card sets'
25   'pysolfc: PySol card sets'
27 options=(
28   debug
30   # https://gitlab.gnome.org/GNOME/aisleriot/-/commit/ca27295085473111564b6674059351a0b6f170c1
31   !lto
33 _commit=e47d8f4e0957e09384c8f1f17a06a660dd94e42f  # tags/3.22.28^0
34 source=("git+https://gitlab.gnome.org/GNOME/aisleriot.git#commit=$_commit")
35 b2sums=('SKIP')
37 pkgver() {
38   cd $pkgname
39   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
42 prepare() {
43   cd $pkgname
46 build() {
47   local meson_options=(
48     # https://gitlab.gnome.org/GNOME/aisleriot/-/commit/ca27295085473111564b6674059351a0b6f170c1
49     -D b_lto=false
51     -D theme_kde=false
52     -D theme_pysol=true
53     -D theme_pysol_path=/usr/share/PySolFC
54   )
56   arch-meson $pkgname build "${meson_options[@]}"
57   meson compile -C build
60 check() {
61   meson test -C build --print-errorlogs
64 package() {
65   meson install -C build --destdir "$pkgdir"
68 # vim:set sw=2 sts=-1 et: