archrelease: copy trunk to extra-x86_64
[arch-packages.git] / alsa-plugins / repos / extra-x86_64 / PKGBUILD
blobfdfb14b94980d928d29ec80df0207f6e23595e90
1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
3 # Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
4 # Contributor: Daniel Ehlers <danielehlers@mindeye.net>
6 pkgbase=alsa-plugins
7 pkgname=(alsa-plugins pulseaudio-alsa)
8 pkgver=1.2.7.1
9 pkgrel=2
10 epoch=1
11 pkgdesc="Additional ALSA plugins"
12 arch=(x86_64)
13 url="https://www.alsa-project.org"
14 license=(LGPL2.1)
15 makedepends=(
16   alsa-lib
17   dbus
18   ffmpeg
19   jack
20   libavtp
21   libpulse
22   libsamplerate
23   speexdsp
25 source=(
26   https://www.alsa-project.org/files/pub/plugins/$pkgbase-$pkgver.tar.bz2{,.sig}
27   pulse-sysdefault.diff
29 sha512sums=('437c05a7e0175594768fd6a9a6d1a158bb4a01a7de6a42c2bd468d9381e01b64d385ddfac7d87baf84fe13cb4e65dc24da643940f416d4b191c528728822d964'
30             'SKIP'
31             'b8c8e55f4da0ae87cc44d75a906d00b4f1e2304e6bc10419c6e0913c8f7d29599a3f3d41733decbe412a4669ea0d5af2a57f85b1655fba3625fbbd33c956f3f9')
32 b2sums=('6f7aa503eda879cd273f36a16eec702b4da9267a60835cb5acbbfe355a83b7ffa3e93eb6483c9946c1d0bcd845a8f574470e7b84c66f793d0d0c6c9883ad52ee'
33         'SKIP'
34         '83c16b77c1737b2b59b60302be22b63e53026a366799fd97fe3c03b86756063d1b9689d5ffc7c793b40db55bdb79a5b6d72a17e0c8aa32364d6e639cf7ad3ce0')
35 validpgpkeys=('F04DF50737AC1A884C4B3D718380596DA6E59C91') # ALSA Release Team (Package Signing Key v1) <release@alsa-project.org>
37 prepare() {
38   cd $pkgbase-$pkgver
40   # Make use of the pulse plugin's "fallback" feature
41   # Keeps parity with our old config from pulseaudio-alsa
42   patch -Np1 -i ../pulse-sysdefault.diff
44   autoreconf -fiv
47 build() {
48   local configure_options=(
49     --prefix=/usr
50     --sysconfdir=/etc
51     --enable-maemo-plugin
52     --enable-maemo-resource-manager
53   )
55   cd $pkgbase-$pkgver
56   ./configure "${configure_options[@]}"
57   # prevent excessive overlinking due to libtool
58   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
59   make
62 package_alsa-plugins() {
63   depends=(
64     alsa-lib libasound.so
65     glibc
66   )
67   optdepends=(
68     'dbus: for maemo plugin'
69     'ffmpeg: for pcm_a52 plugin'
70     'jack: for pcm_jack plugin'
71     'libavtp: for pcm_aaf plugin'
72     'libsamplerate: for rate_samplerate plugin'
73     'libpulse: for conf_pulse, ctl_pulse and pcm_pulse plugins'
74     'speexdsp: for pcm_speex and rate_speexrate plugins'
75   )
77   cd $pkgbase-$pkgver
78   make DESTDIR="$pkgdir" install
79   install -vDm 644 doc/README* doc/*.txt -t "$pkgdir/usr/share/doc/$pkgbase"
81   # remove maemo plugin configuration (it overrides defaults for pcm and ctl),
82   # until a better way is found to package default overrides:
83   # https://bugs.archlinux.org/task/65440
84   rm -v "$pkgdir/etc/alsa/conf.d/98-maemo.conf"
86   # make a proper off-by-default config template out of the example file
87   mv -v "$pkgdir/etc/alsa/conf.d/99-pulseaudio-default.conf.example" "$pkgdir/usr/share/alsa/alsa.conf.d/99-pulseaudio-default.conf"
90 package_pulseaudio-alsa() {
91   pkgdesc="ALSA Configuration for PulseAudio"
92   depends=(
93     'alsa-plugins>=1.2.2-2'
94     pulseaudio
95   )
97   install -vdm 755 "$pkgdir/etc/alsa/conf.d"
98   ln -st "$pkgdir/etc/alsa/conf.d" /usr/share/alsa/alsa.conf.d/99-pulseaudio-default.conf
101 # vim:set sw=2 et: