archrelease: copy trunk to extra-x86_64
[arch-packages.git] / artikulate / trunk / PKGBUILD
blob767b878b7505128c1e87f19e2171a95dc8843b5e
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=artikulate
6 pkgver=23.04.1
7 pkgrel=1
8 pkgdesc='Improve your pronunciation by listening to native speakers'
9 url='https://apps.kde.org/artikulate/'
10 arch=(x86_64)
11 license=(GPL LGPL FDL)
12 groups=(kde-applications kde-education)
13 depends=(hicolor-icon-theme knewstuff kirigami2 qt5-xmlpatterns)
14 makedepends=(extra-cmake-modules kdoctools)
15 source=(https://download.kde.org/stable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz{,.sig})
16 sha256sums=('d1928ca183f29b6e9532959ab525fc34520724c1e40b962d737fa55115f78fbf'
17             'SKIP')
18 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7  # Albert Astals Cid <aacid@kde.org>
19               F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87  # Christoph Feck <cfeck@kde.org>
20               D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
22 build() {
23   cmake -B build -S $pkgname-$pkgver \
24     -DBUILD_TESTING=OFF
25   cmake --build build
28 package() {
29   DESTDIR="$pkgdir" cmake --install build