1 # Maintainer: Lukas Fleischer <lfleischer@archlinux.org>
2 # Contributor: Allan McRae <allan@archlinux.org>
3 # Contributor: Andreas Radke <andyrtr@archlinux.org>
8 pkgdesc="A GNU tool for automatically configuring source code"
10 license=('GPL2' 'GPL3' 'custom')
11 url="https://www.gnu.org/software/autoconf"
12 depends=('awk' 'm4' 'diffutils' 'perl' 'sh')
13 checkdepends=('gcc-fortran')
15 "https://ftp.gnu.org/pub/gnu/${pkgname}/${pkgname}-${pkgver}.tar.xz"{,.sig}
16 $pkgname-2.71-bash5.2.patch::https://github.com/autotools-mirror/autoconf/commit/412166e185c00d6eacbe67dfcb0326f622ec4020.patch
18 sha256sums=('f14c83cfebcc9427f2c3cea7258bd90df972d92eb26752da4ddad81c87a0faa4'
20 'ee07bb3f9692bed2b7689bd361ae4e2e9a1bd852864a0c98f90b7b4c8beddfe4')
21 validpgpkeys=('82F854F3CE73174B8B63174091FCC32B6769AA64') # Zack Weinberg
24 # fix build for bash >= 5.2
25 patch -Np1 -d $pkgname-$pkgver -i ../$pkgname-2.71-bash5.2.patch
29 cd "${pkgname}-${pkgver}"
30 ./configure --prefix=/usr
35 cd "${pkgname}-${pkgver}"
36 # disable test 227 as it is broken
37 make check TESTSUITEFLAGS="1-226 228-"
41 cd "${pkgname}-${pkgver}"
42 make DESTDIR="${pkgdir}" install
45 install -Dm644 COPYING.EXCEPTION "$pkgdir"/usr/share/licenses/autoconf/COPYING.EXCEPTION
47 # remove unwanted file
48 rm -f "$pkgdir"/usr/share/info/standards.info