archrelease: copy trunk to extra-x86_64
[arch-packages.git] / automake / trunk / PKGBUILD
blob9cf88799c8cfbf1391d478e5249781fa46ad37c1
1 # Maintainer: Lukas Fleischer <lfleischer@archlinux.org>
2 # Contributor: Allan McRae <allan@archlinux.org>
3 # Contributor: judd <jvinet@zeroflux.org>
5 pkgname=automake
6 pkgver=1.16.5
7 pkgrel=2
8 pkgdesc="A GNU tool for automatically creating Makefiles"
9 arch=('any')
10 license=('GPL')
11 url="https://www.gnu.org/software/automake"
12 depends=('perl' 'bash')
13 makedepends=('autoconf')
14 checkdepends=('dejagnu' 'gcc-fortran' 'java-environment' 'vala' 'emacs' 'cscope'
15               'expect' 'ncompress' 'gettext' 'lzip' 'zip' 'sharutils' 'help2man'
16               # disable TeX tests for now, lots of them fail and need upstream
17               # fixes for current texlive release
18               #'texlive-bin' 'texinfo'
19               'python' 'python-virtualenv')
20 source=("https://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.xz"{,.sig})
21 sha512sums=('3084ae543aa3fb5a05104ffb2e66cfa9a53080f2343c44809707fd648516869511500dba50dae67ff10f92a1bf3b5a92b2a0fa01cda30adb69b9da03994d9d88'
22             'SKIP')
23 validpgpkeys=('E1622F96D2BB4E58018EEF9860F906016E407573'   # Stefano Lattarini
24               'F2A38D7EEB2B66405761070D0ADEE10094604D37'   # Mathieu Lirzin
25               '155D3FC500C834486D1EEA677FD9FCCB000BEEEE')  # Jim Meyering
27 build() {
28         cd "${pkgname}-${pkgver}"
29         ./configure --build=$CHOST --prefix=/usr
30         make
33 check() {
34         cd "${pkgname}-${pkgver}"
35         make check
38 package() {
39         cd "${pkgname}-${pkgver}"
40         make DESTDIR="${pkgdir}" install