archrelease: copy trunk to extra-x86_64
[arch-packages.git] / beanshell / trunk / PKGBUILD
blob857724d030709c8cc378819840c096d21d159c40
1 # Maintainer: AndyRTR <andyrtr at archlinux.org>
3 pkgname=beanshell
4 pkgver=2.1.1
5 pkgrel=1
6 pkgdesc="Small, free, embeddable, source level Java interpreter with object based scripting language features written in Java"
7 arch=('any')
8 url="https://github.com/beanshell/beanshell"
9 license=('Apache')
10 depends=('java-runtime')
11 provides=('bsh')
12 replaces=('beanshell2')
13 conflicts=('beanshell2')
14 source=("https://github.com/beanshell/beanshell/releases/download/$pkgver/bsh-${pkgver}.jar")
15 noextract=("${pkgname}-${pkgver}.jar")
16 sha512sums=('73723d4bd834e1c9564f964e0008b2110dceb8dee2874eab4529fda1d8e20572f1198eedec235a08ad39c395c3737e8f5b7517077c3604d644506f883f0a3919')
18 # beanshell2 fork is dead
19 # http://stackoverflow.com/questions/26549307/current-state-of-beanshell
20 # https://github.com/stain/beanshell2 - google code got removed and only this fork is left and outdated 
21 # original url http://www.beanshell.org - unmaintained
23 # Fedora and our only package making use of it use the follow up of the old beanshell:
24 # https://github.com/beanshell/beanshell
26 package() {
27   install -m755 -d "${pkgdir}"/usr/share/java/
28   install -D -m644 "${srcdir}"/bsh-${pkgver}.jar "${pkgdir}"/usr/share/java/bsh.jar