archrelease: copy trunk to extra-x86_64
[arch-packages.git] / bird / trunk / PKGBUILD
blob6c62c682f425972ce6c7d3c6807fab15e38f540b
1 # Maintainer: Sébastien Luttringer
3 pkgname=bird
4 pkgver=2.13
5 pkgrel=1
6 pkgdesc='RIP, OSPF, BGP, MPLS, BFD, Babel routing daemon'
7 arch=('x86_64')
8 url='https://bird.network.cz/'
9 license=('GPL2')
10 backup=('etc/bird.conf')
11 depends=('glibc' 'readline' 'ncurses' 'libssh')
12 replaces=('bird6')
13 options=(!emptydirs)
14 source=("https://bird.network.cz/download/$pkgname-$pkgver.tar.gz"
15         'bird.service'
16         )
17 sha256sums=('8d895e3e311880e9efb888b4386cbec2f7e18bfb8334e8d4c8ca7c4341092638'
18             '4aa1e8d41229badd276aa3747f613e7df34761892add2258c63bdb5097dfeb2b')
20 prepare() {
21   cd $pkgname-$pkgver
22   # apply patch from the source array (should be a pacman feature)
23   local filename
24   for filename in "${source[@]}"; do
25     if [[ "$filename" =~ \.patch$ ]]; then
26       echo "Applying patch ${filename##*/}"
27       patch -p1 -N -i "$srcdir/${filename##*/}"
28     fi
29   done
30   :
33 build() {
34   cd $pkgbase-$pkgver
35   ./configure \
36     --prefix=/usr \
37     --sbindir=/usr/bin \
38     --sysconfdir=/etc \
39     --localstatedir=/var \
40     --runstatedir=/run/$pkgname \
41     --docdir=/usr/share/doc/$pkgname
42   make
45 package () {
47   cd $pkgbase-$pkgver
48   make DESTDIR="$pkgdir" install
50   # systemd
51   install -D -m 644 "$srcdir/bird.service" "$pkgdir/usr/lib/systemd/system/bird.service"
54 # vim:set ts=2 sw=2 et: