archrelease: copy trunk to extra-x86_64
[arch-packages.git] / black-hole-solver / trunk / PKGBUILD
blobc22539c9717138b8d67c11895423986db64297e9
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=black-hole-solver
4 pkgver=1.12.0
5 pkgrel=1
6 pkgdesc="Solvers and statistics for 'Golf' solitaire, 'Black Hole' solitaire, 'All in a Row' solitaire and related card patience games"
7 arch=(x86_64)
8 url='https://www.shlomifish.org/open-source/projects/black-hole-solitaire-solver/'
9 license=(MIT)
10 depends=(glibc)
11 makedepends=(cmake perl-path-tiny rinutils python)
12 source=(https://fc-solve.shlomifish.org/downloads/fc-solve/black-hole-solver-$pkgver.tar.xz)
13 sha256sums=('d32f32536f7573292588f41bb0d85ae42d561376c218dc4ab6badfe4904a37a7')
15 build() {
16   cmake -B build -S $pkgname-$pkgver \
17     -DCMAKE_INSTALL_PREFIX=/usr \
18     -DBUILD_STATIC_LIBRARY=OFF
19   cmake --build build
22 package() {
23   DESTDIR="$pkgdir" cmake --install build
24   install -Dm644 $pkgname-$pkgver/COPYING "$pkgdir"/usr/share/licenses/$pkgname/LICENSE