archrelease: copy trunk to extra-x86_64
[arch-packages.git] / botan2 / trunk / PKGBUILD
blobc9d1b574449a171800211df600d2e79c2e6338e1
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Alexander F. Rødseth <xyproto@archlinux.org>
3 # Contributor: Angel Velasquez <angvp@archlinux.org>
4 # Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
5 # Contributor: d'Ronin <daronin@2600.com>
6 # Contributor: Hexchain Tong <richard0053@gmail.com>
7 # Contributor: Jack Lloyd <jack@randombit.net>
9 pkgname=botan2
10 pkgver=2.19.3
11 pkgrel=1
12 pkgdesc='Crypto library written in C++ (legacy version)'
13 arch=(x86_64)
14 url='https://botan.randombit.net/'
15 license=(BSD)
16 depends=(xz sqlite)
17 makedepends=(python boost)
18 optdepends=('python: for using botan2.py')
19 source=(https://botan.randombit.net/releases/Botan-${pkgver}.tar.xz{,.asc})
20 sha256sums=('dae047f399c5a47f087db5d3d9d9e8f11ae4985d14c928d71da1aff801802d55'
21             'SKIP')
22 validpgpkeys=('621DAF6411E1851C4CF9A2E16211EBF1EFBADFBC') # Botan Distribution Key
24 build() {
25   cd Botan-$pkgver
27   ./configure.py \
28     --prefix=/usr \
29     --with-bzip \
30     --with-lzma \
31     --with-zlib \
32     --with-boost \
33     --with-sqlite3 \
34     --with-os-feature=getrandom \
35     --build-targets=shared,tests
36   make
39 check() {
40   cd Botan-$pkgver
42   LD_LIBRARY_PATH="$PWD" ./botan-test
45 package() {
46   DESTDIR="$pkgdir" make -C Botan-$pkgver install
47   install -Dm644 Botan-$pkgver/license.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE