archrelease: copy trunk to extra-x86_64
[arch-packages.git] / brasero / repos / extra-x86_64 / PKGBUILD
blobea8e6c438ad1eae0023e5b75a3e3ec5d45b32fef
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Allan McRae <allan@archlinux.org>
3 # Contributor: Jan de Groot <jgc@archlinux.org>
4 # Contributor: William Rea <sillywilly@gmail.com>
6 pkgname=brasero
7 pkgver=3.12.3+r24+gd01ba738
8 pkgrel=1
9 pkgdesc="CD/DVD mastering tool"
10 url="https://wiki.gnome.org/Apps/Brasero"
11 arch=(x86_64)
12 license=(GPL)
13 depends=(gtk3 gst-plugins-good totem-plparser cdrtools cdrdao shared-mime-info
14          libcanberra dvd+rw-tools dconf libsm libnotify gvfs tracker3)
15 makedepends=(gtk-doc yelp-tools gnome-common intltool libburn libisofs
16              gobject-introspection itstool docbook-xsl git)
17 optdepends=('libburn: alternative back-end'
18             'libisofs: libburn back-end'
19             'dvdauthor: video project'
20             'vcdimager: video project')
21 options=(debug)
22 _commit=d01ba738eb22502852fdc6001d2422bc7af04116  # master
23 source=("git+https://gitlab.gnome.org/GNOME/brasero.git#commit=$_commit")
24 sha256sums=('SKIP')
26 pkgver() {
27   cd brasero
28   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
31 prepare() {
32   cd brasero
33   NOCONFIGURE=1 ./autogen.sh
36 build() {
37   cd brasero
38   ./configure \
39     --prefix=/usr \
40     --sysconfdir=/etc \
41     --localstatedir=/var \
42     --disable-caches \
43     --disable-search \
44     --disable-schemas-compile \
45     --enable-compile-warnings=minimum \
46     --enable-gtk-doc
47   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
48   make
51 package() {
52   cd brasero
53   make DESTDIR="$pkgdir" install