archrelease: copy trunk to extra-x86_64
[arch-packages.git] / breezy / trunk / PKGBUILD
blob6e9047d7591e7b4fd8479429a4bf4486239eb125
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Adam Fontenot <adam.m.fontenot@gmail.com>
4 pkgname=breezy
5 pkgver=3.3.2
6 pkgrel=4
7 pkgdesc='A decentralized revision control system with support for Bazaar and Git file formats'
8 arch=(x86_64)
9 url=https://www.breezy-vcs.org/
10 license=(GPL2)
11 depends=(
12   python-configobj
13   python-dulwich
14   python-fastbencode
15   python-merge3
16   python-patiencediff
17   python-six
18   python-yaml
20 makedepends=(
21   cython
22   git
23   python-fastimport
24   python-gpgme
25   python-packaging
26   python-paramiko
27   python-setuptools
28   python-setuptools-gettext
29   python-setuptools-rust
31 optdepends=(
32   'python-fastimport: Fastimport support'
33   'python-gpgme: PGP support'
34   'python-paramiko: access branches over SFTP'
36 provides=(bzr)
37 conflicts=(bzr)
38 replaces=(bzr)
39 _tag=b4742dfba252059a1dde2dcc94947dd0516075ac
40 source=(git+https://github.com/breezy-team/breezy.git#tag=${_tag})
41 sha256sums=(SKIP)
43 pkgver() {
44   cd breezy
45   git describe --tags | sed 's/brz-//; s/-/./g'
48 build() {
49   cd breezy
50   python setup.py build
53 package() {
54   cd breezy
55   python setup.py install --root="${pkgdir}" --install-data=usr/share --optimize=1 --skip-build
56   ln -s brz "${pkgdir}"/usr/bin/bzr # backwards compatibility
59 # vim: ts=2 sw=2 et: