1 # Maintainer: Juergen Hoetzel <juergen@archlinux.org>
5 pkgdesc="ANSI Common Lisp interpreter, compiler and debugger"
8 url="https://clisp.sourceforge.io/"
9 depends=('readline' 'libsigsegv' 'ffcall' 'libxcrypt' 'libunistring')
10 provides=('common-lisp')
11 makedepends=('mercurial')
12 options=('!makeflags' '!emptydirs')
13 _rev=b55b8196c9f25428304ec3de87383319fd1f2264
14 source=(hg+http://hg.code.sf.net/p/clisp/clisp#revision=$_rev)
19 CFLAGS+=" -ffat-lto-objects" \
20 ./configure --prefix=/usr --with-readline --with-ffcall src
23 ./makemake --prefix=/usr --with-readline --with-ffcall --with-dynamic-ffi > Makefile
34 make DESTDIR="$pkgdir" install