archrelease: copy trunk to extra-x86_64
[arch-packages.git] / clutter-gst / repos / extra-x86_64 / PKGBUILD
blobbd9314a64d148c0909acf3153c7a52fd74c43ac4
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=clutter-gst
4 pkgver=3.0.27
5 pkgrel=4
6 pkgdesc="GStreamer bindings for clutter"
7 url="https://gitlab.gnome.org/GNOME/clutter-gst"
8 arch=(x86_64)
9 license=(LGPL)
10 depends=(clutter gst-plugins-base-libs libxdamage libgudev gdk-pixbuf2)
11 makedepends=(gobject-introspection gtk-doc git gst-plugins-good)
12 optdepends=("gst-plugins-good: Video camera capture")
13 options=(debug)
14 _commit=01a461da1bdb3b29edd2d198b877ec0765af1f39  # tags/3.0.27^0
15 source=("git+https://gitlab.gnome.org/GNOME/clutter-gst.git#commit=$_commit"
16         0001-video-sink-Remove-RGBx-BGRx-support.patch)
17 sha256sums=('SKIP'
18             '818d20462b9ac623e036d205dc28c07e17045f913fa652a79f73996310be067a')
20 pkgver() {
21   cd $pkgname
22   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
25 prepare() {
26   cd $pkgname
28   # https://bugs.archlinux.org/task/74222
29   git apply -3 ../0001-video-sink-Remove-RGBx-BGRx-support.patch
31   NOCONFIGURE=1 ./autogen.sh
34 build() {
35   cd $pkgname
36   ./configure --prefix=/usr --sysconfdir=/etc --enable-gtk-doc
38   # https://bugzilla.gnome.org/show_bug.cgi?id=655517
39   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
41   make
44 check() {
45   cd $pkgname
46   make check
49 package() {
50   cd $pkgname
51   make DESTDIR="$pkgdir" install
54 # vim:set sw=2 et: