archrelease: copy trunk to extra-x86_64
[arch-packages.git] / clutter-gst / trunk / PKGBUILD
blob19a0f10218a03e5da3c16c9f0edea228d3400991
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=clutter-gst
4 pkgver=3.0.27
5 pkgrel=4
6 pkgdesc="GStreamer bindings for clutter"
7 url="https://gitlab.gnome.org/GNOME/clutter-gst"
8 arch=(x86_64)
9 license=(LGPL)
10 depends=(clutter gst-plugins-base-libs libxdamage libgudev gdk-pixbuf2)
11 makedepends=(gobject-introspection gtk-doc git gst-plugins-good)
12 optdepends=("gst-plugins-good: Video camera capture")
13 _commit=01a461da1bdb3b29edd2d198b877ec0765af1f39  # tags/3.0.27^0
14 source=("git+https://gitlab.gnome.org/GNOME/clutter-gst.git#commit=$_commit"
15         0001-video-sink-Remove-RGBx-BGRx-support.patch)
16 sha256sums=('SKIP'
17             '818d20462b9ac623e036d205dc28c07e17045f913fa652a79f73996310be067a')
19 pkgver() {
20   cd $pkgname
21   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
24 prepare() {
25   cd $pkgname
27   # https://bugs.archlinux.org/task/74222
28   git apply -3 ../0001-video-sink-Remove-RGBx-BGRx-support.patch
30   NOCONFIGURE=1 ./autogen.sh
33 build() {
34   cd $pkgname
35   ./configure --prefix=/usr --sysconfdir=/etc --enable-gtk-doc
37   # https://bugzilla.gnome.org/show_bug.cgi?id=655517
38   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
40   make
43 check() {
44   cd $pkgname
45   make check
48 package() {
49   cd $pkgname
50   make DESTDIR="$pkgdir" install
53 # vim:set sw=2 et: