archrelease: copy trunk to extra-x86_64
[arch-packages.git] / clutter-gtk / trunk / PKGBUILD
blob02e53274c8b840813f037d11d21c6dc30ad21130
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=clutter-gtk
5 pkgver=1.8.4
6 pkgrel=3
7 pkgdesc="Clutter integration with GTK+"
8 url="https://gitlab.gnome.org/GNOME/clutter-gtk"
9 arch=(x86_64)
10 license=(LGPL)
11 depends=(clutter)
12 makedepends=(gobject-introspection gtk-doc git meson)
13 _commit=77483ba46384adde76f6c4599eae77eeec852c56  # tags/1.8.4^0
14 source=("git+https://gitlab.gnome.org/GNOME/clutter-gtk.git#commit=$_commit")
15 sha256sums=('SKIP')
17 pkgver() {
18   cd $pkgname
19   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
22 prepare() {
23   cd $pkgname
26 build() {
27   arch-meson $pkgname build -Denable_docs=true
28   meson compile -C build
31 package() {
32   meson install -C build --destdir "$pkgdir"
35 # vim:set sw=2 et: