archrelease: copy trunk to extra-x86_64
[arch-packages.git] / clutter / repos / extra-x86_64 / PKGBUILD
blobcfbafcba1499f96397e2429448122532e133e6b2
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
3 # Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
4 # Contributor: William Rea <sillywilly@gmail.com>
6 pkgname=clutter
7 pkgver=1.26.4
8 pkgrel=2
9 pkgdesc="A toolkit for creating fast, portable, compelling dynamic UIs"
10 url="https://blogs.gnome.org/clutter/"
11 arch=(x86_64)
12 license=(LGPL)
13 depends=(gtk3 cogl libinput)
14 makedepends=(gobject-introspection gtk-doc git)
15 options=(debug)
16 _commit=fd85623d34a54b3f5607011086cf19cb2c756a6a  # tags/1.26.4^0
17 source=("git+https://gitlab.gnome.org/GNOME/clutter.git#commit=$_commit")
18 sha256sums=('SKIP')
20 pkgver() {
21   cd $pkgname
22   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
25 prepare() {
26   cd $pkgname
27   NOCONFIGURE=1 ./autogen.sh
30 build() {
31   cd $pkgname
32   ./configure --prefix=/usr \
33     --enable-introspection \
34     --enable-egl-backend \
35     --enable-gdk-backend \
36     --enable-wayland-backend \
37     --enable-x11-backend \
38     --enable-evdev-input \
39     --enable-wayland-compositor \
40     --enable-gtk-doc
42   # https://bugzilla.gnome.org/show_bug.cgi?id=655517
43   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
45   make
48 package() {
49   depends+=(libcogl{,-pango,-path}.so)
50   provides+=(libclutter-1.0.so)
52   cd "$pkgname"
53   make DESTDIR="$pkgdir" install
56 # vim:set sw=2 et: