archrelease: copy trunk to extra-x86_64
[arch-packages.git] / coreutils / repos / core-x86_64 / PKGBUILD
blob3a371b127fa6ea2d8a8d29f4ccac6cd80a74a7ac
1 # Maintainer: Sébastien "Seblu" Luttringer
2 # Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
3 # Contributor: Allan McRae <allan@archlinux.org>
4 # Contributor: judd <jvinet@zeroflux.org>
6 pkgname=coreutils
7 pkgver=9.3
8 pkgrel=1
9 pkgdesc='The basic file, shell and text manipulation utilities of the GNU operating system'
10 arch=('x86_64')
11 license=('GPL3')
12 url='https://www.gnu.org/software/coreutils/'
13 depends=('glibc' 'acl' 'attr' 'gmp' 'libcap' 'openssl')
14 source=("https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz"{,.sig})
15 validpgpkeys=('6C37DC12121A5006BC1DB804DF6FD971306037D9') # Pádraig Brady
16 sha256sums=('adbcfcfe899235b71e8768dcf07cd532520b7f54f9a8064843f8d199a904bbaa'
17             'SKIP')
19 prepare() {
20   cd $pkgname-$pkgver
21   # apply patch from the source array (should be a pacman feature)
22   local src
23   for src in "${source[@]}"; do
24     src="${src%%::*}"
25     src="${src##*/}"
26     [[ $src = *.patch ]] || continue
27     echo "Applying patch $src..."
28     patch -Np1 < "../$src"
29   done
32 build() {
33   cd $pkgname-$pkgver
34   ./configure \
35       --prefix=/usr \
36       --libexecdir=/usr/lib \
37       --with-openssl \
38       --enable-no-install-program=groups,hostname,kill,uptime
39   make
42 check() {
43   cd $pkgname-$pkgver
44   make check
47 package() {
48   cd $pkgname-$pkgver
49   make DESTDIR="$pkgdir" install
52 # vim:set ts=2 sw=2 et: