1 # Maintainer: Sébastien "Seblu" Luttringer
2 # Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
3 # Contributor: Allan McRae <allan@archlinux.org>
4 # Contributor: judd <jvinet@zeroflux.org>
9 pkgdesc='The basic file, shell and text manipulation utilities of the GNU operating system'
12 url='https://www.gnu.org/software/coreutils/'
13 depends=('glibc' 'acl' 'attr' 'gmp' 'libcap' 'openssl')
14 source=("https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz"{,.sig})
15 validpgpkeys=('6C37DC12121A5006BC1DB804DF6FD971306037D9') # Pádraig Brady
16 sha256sums=('adbcfcfe899235b71e8768dcf07cd532520b7f54f9a8064843f8d199a904bbaa'
21 # apply patch from the source array (should be a pacman feature)
23 for src in "${source[@]}"; do
26 [[ $src = *.patch ]] || continue
27 echo "Applying patch $src..."
28 patch -Np1 < "../$src"
36 --libexecdir=/usr/lib \
38 --enable-no-install-program=groups,hostname,kill,uptime
49 make DESTDIR="$pkgdir" install
52 # vim:set ts=2 sw=2 et: