archrelease: copy trunk to extra-x86_64
[arch-packages.git] / dbus / repos / core-x86_64 / PKGBUILD
blob4268c4c57033bf50c2bb6cf252eb9652d048b864
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
3 # Contributor: Tom Gundersen <teg@jklm.no>
4 # Contributor: Link Dupont <link@subpop.net>
6 pkgbase=dbus
7 pkgname=(
8   dbus
9   dbus-docs
11 pkgver=1.14.6
12 pkgrel=2
13 pkgdesc="Freedesktop.org message bus system"
14 url="https://wiki.freedesktop.org/www/Software/dbus/"
15 arch=(x86_64)
16 license=(
17   GPL
18   custom
20 depends=(
21   audit
22   expat
23   systemd-libs
25 makedepends=(
26   autoconf-archive
27   docbook-xsl
28   doxygen
29   git
30   python
31   systemd
32   xmlto
33   yelp-tools
35 source=(
36   "git+https://gitlab.freedesktop.org/dbus/dbus.git?signed#tag=dbus-$pkgver"
37   dbus-reload.hook
39 b2sums=('SKIP'
40         '05ab81bf72e7cf45ad943f5b84eaecef4f06bed94979c579a3e23134cbabd7ea6f65fa9ac252f8b43ceb4a3295e0d2325f06560a044fe7ddf125fc30dfc2b7e2')
41 validpgpkeys=('DA98F25C0871C49A59EAFF2C4DE8FF2A63C7CC90') # Simon McVittie <simon.mcvittie@collabora.co.uk>
43 prepare() {
44   cd dbus
46   NOCONFIGURE=1 ./autogen.sh
49 build() {
50   local configure_options=(
51     --prefix=/usr
52     --sysconfdir=/etc
53     --localstatedir=/var
54     --libexecdir=/usr/lib/dbus-1.0
55     --runstatedir=/run
56     --with-console-auth-dir=/run/console/
57     --with-dbus-user=dbus
58     --with-system-pid-file=/run/dbus/pid
59     --with-system-socket=/run/dbus/system_bus_socket
60     --with-systemdsystemunitdir=/usr/lib/systemd/system
61     --enable-inotify
62     --enable-libaudit
63     --enable-systemd
64     --enable-user-session
65     --enable-xml-docs
66     --enable-doxygen-docs
67     --enable-ducktype-docs
68     --disable-static
69     --without-x
70   )
72   cd dbus
73   ./configure "${configure_options[@]}"
74   make
77 check() {
78   make -C dbus -j1 check
81 package_dbus() {
82   depends+=(
83     libaudit.so
84     libsystemd.so
85   )
86   provides=(
87     libdbus
88     libdbus-1.so
89   )
90   conflicts=(libdbus)
91   replaces=(libdbus)
93   DESTDIR="$pkgdir" make -C dbus install
95   rm -r "$pkgdir"/{etc,var}
97   # We have a pre-assigned uid (81)
98   echo 'u dbus 81 "System Message Bus"' |
99     install -Dm644 /dev/stdin "$pkgdir/usr/lib/sysusers.d/dbus.conf"
101   install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 *.hook
103   # Split docs
104   mkdir -p doc/usr/share
105   mv {"$pkgdir",doc}/usr/share/doc
107   install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 dbus/COPYING
110 package_dbus-docs() {
111   pkgdesc+=" - Documentation"
112   depends=()
114   mv doc/* "$pkgdir"
116   install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 dbus/COPYING
119 # vim:set sw=2 sts=-1 et: