archrelease: copy trunk to extra-x86_64
[arch-packages.git] / dconf-editor / trunk / PKGBUILD
blob3ac6fb8503fee789888ec27971f94ac860219079
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=dconf-editor
4 pkgver=43.0
5 pkgrel=1
6 pkgdesc="GSettings editor for GNOME"
7 url="https://wiki.gnome.org/Apps/DconfEditor"
8 arch=(x86_64)
9 license=(GPL3)
10 groups=(gnome-extra)
11 depends=(libhandy dconf)
12 makedepends=(vala meson git)
13 _commit=27b4f9d1d53783507f03eb9b6a140f0646ce746e  # tags/43.0^0
14 source=("git+https://gitlab.gnome.org/GNOME/dconf-editor.git#commit=$_commit")
15 sha256sums=('SKIP')
17 pkgver() {
18   cd $pkgname
19   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
22 prepare() {
23   cd $pkgname
26 build() {
27   arch-meson $pkgname build
28   meson compile -C build
31 check() {
32   meson test -C build --print-errorlogs
35 package() {
36   meson install -C build --destdir "$pkgdir"
39 # vim:set sw=2 sts=-1 et: