archrelease: copy trunk to extra-x86_64
[arch-packages.git] / dleyna / trunk / PKGBUILD
bloba0ef2c2ef356780101fd3bbf13f3789e5858739a
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgbase=dleyna
4 pkgname=(dleyna dleyna-docs)
5 pkgver=0.8.2
6 pkgrel=2
7 pkgdesc="Services and D-Bus APIs to access UPnP and DLNA media devices"
8 url="https://gitlab.gnome.org/World/dLeyna"
9 arch=(x86_64)
10 license=(LGPL2.1)
11 depends=(
12   dbus
13   gupnp
14   gupnp-av
15   gupnp-dlna
16   libsoup3
17   libxml2
19 makedepends=(
20   git
21   meson
22   python-docutils
23   python-gobject
24   python-sphinx
25   python-sphinx_rtd_theme
27 _commit=9444b8eb9e48a3985340c7f7e0d3a63d2b352302  # tags/v0.8.2^0
28 source=("git+https://gitlab.gnome.org/World/dLeyna.git#commit=$_commit")
29 sha256sums=('SKIP')
31 pkgver() {
32   cd dLeyna
33   git describe --tags | sed 's/^v//;s/[^-]*-g/r&/;s/-/+/g'
36 prepare() {
37   cd dLeyna
40 build() {
41   local meson_options=(
42     -D log_type=glib
43   )
45   arch-meson dLeyna build "${meson_options[@]}"
46   meson compile -C build
47   meson compile -C build docs
50 check() {
51   meson test -C build --print-errorlogs
54 package_dleyna() {
55   provides=(
56     dleyna-connector-dbus
57     dleyna-core
58     dleyna-renderer
59     dleyna-server
60     libdleyna-core-1.0.so
61   )
62   replaces=(
63     'dleyna-connector-dbus<=0.4.1-1'
64     'dleyna-core<=0.7.0-3'
65     'dleyna-renderer<=0.7.2-1'
66     'dleyna-server<=0.7.2-1'
67   )
68   conflicts=("${replaces[@]}")
70   meson install -C build --destdir "$pkgdir"
72   python -m compileall -d /usr/lib "$pkgdir/usr/lib"
73   python -O -m compileall -d /usr/lib "$pkgdir/usr/lib"
76 package_dleyna-docs() {
77   pkgdesc+=" (documentation)"
78   depends=()
80   mkdir -p "$pkgdir/usr/share/doc"
81   cp -a build/doc/docs "$pkgdir/usr/share/doc/$pkgbase"
84 # vim:set sw=2 sts=-1 et: