1 # Maintainer: Andreas Radke <andyrtr@archlinux.org>
3 # Contributor: Chris Severance aur.severach aATt spamgourmet dott com
4 # Contributor: Andreas B. Wagner <AndreasBWagner@gmail.com>
9 pkgdesc="Legacy docbook-sgml"
11 url='https://www.docbook.org/sgml/'
13 depends=('sgml-common')
14 install=$pkgname.install
15 source=("https://www.docbook.org/sgml/${pkgver}/docbk31.zip")
16 sha256sums=('20261d2771b9a052abfa3d8fab1aa62be05791a010281c566f9073bf0e644538')
20 # This command removes the ENT definitions from the catalog file.
21 # This command replaces the DTDDECL catalog entry, which is not supported by Linux SGML tools,
22 # with the SGMLDECL catalog entry.
23 sed -i -e '/ISO 8879/d' \
24 -e 's|DTDDECL "-//OASIS//DTD DocBook V3.1//EN"|SGMLDECL|g' \
31 local DTDDIR="usr/share/sgml/docbook-sgml-${pkgver}"
33 install -dm755 "$pkgdir/$DTDDIR"
34 install -m644 docbook.cat "$pkgdir/$DTDDIR/catalog"
35 install -m644 *.dtd *.mod *.dcl "$pkgdir/$DTDDIR"