archrelease: copy trunk to extra-x86_64
[arch-packages.git] / docbook-sgml31 / trunk / PKGBUILD
blob78cfbc7df02799826a35eff9b2d7886d450b445a
1 # Maintainer: Andreas Radke <andyrtr@archlinux.org>
3 # Contributor: Chris Severance aur.severach aATt spamgourmet dott com
4 # Contributor: Andreas B. Wagner <AndreasBWagner@gmail.com>
6 pkgname=docbook-sgml31
7 pkgver=3.1
8 pkgrel=5
9 pkgdesc="Legacy docbook-sgml"
10 arch=('any')
11 url='https://www.docbook.org/sgml/'
12 license=('MIT')
13 depends=('sgml-common')
14 install=$pkgname.install
15 source=("https://www.docbook.org/sgml/${pkgver}/docbk31.zip")
16 sha256sums=('20261d2771b9a052abfa3d8fab1aa62be05791a010281c566f9073bf0e644538')
18 build() {
19   cd "$srcdir"
20   # This command removes the ENT definitions from the catalog file.
21   # This command replaces the DTDDECL catalog entry, which is not supported by Linux SGML tools, 
22   # with the SGMLDECL catalog entry.
23   sed -i -e '/ISO 8879/d' \
24          -e 's|DTDDECL "-//OASIS//DTD DocBook V3.1//EN"|SGMLDECL|g' \
25          docbook.cat
28 package() {
29   cd "$srcdir"
31   local DTDDIR="usr/share/sgml/docbook-sgml-${pkgver}"
33   install -dm755 "$pkgdir/$DTDDIR"
34   install -m644 docbook.cat "$pkgdir/$DTDDIR/catalog"
35   install -m644 *.dtd *.mod *.dcl "$pkgdir/$DTDDIR"