archrelease: copy trunk to extra-x86_64
[arch-packages.git] / eigen / trunk / PKGBUILD
blob3f30931a9bddac6b9aebfab088cd9f31e60a4516
1 # Maintainer: Ronald van Haren <ronald@archlinux.org>
2 # Contributor: Chirantan Ekbote <chirantan.ekbote at gmail.com>
3 # Contributor: Kringel
5 pkgname=eigen
6 pkgver=3.4.0
7 pkgrel=1
8 pkgdesc='Lightweight C++ template library for vector and matrix math, a.k.a. linear algebra'
9 arch=(any)
10 url='https://eigen.tuxfamily.org'
11 license=(GPL3 LGPL2.1 BSD custom:MPL2 custom:MINPACK)
12 makedepends=(cmake freeglut gcc-fortran fftw suitesparse boost)
13 source=(https://gitlab.com/libeigen/eigen/-/archive/$pkgver/$pkgname-$pkgver.tar.gz)
14 sha256sums=('8586084f71f9bde545ee7fa6d00288b264a2b7ac3607b974e54d13e7162c1c72')
16 build() {
17   cmake -B build -S $pkgname-$pkgver \
18     -DCMAKE_INSTALL_PREFIX=/usr
21 package() {
22   DESTDIR="$pkgdir" cmake --install build
24   # install custom licenses
25   install -Dm644 $pkgname-$pkgver/COPYING.* -t "$pkgdir/usr/share/licenses/$pkgname"