1 # Maintainer: Ronald van Haren <ronald@archlinux.org>
2 # Contributor: Chirantan Ekbote <chirantan.ekbote at gmail.com>
8 pkgdesc='Lightweight C++ template library for vector and matrix math, a.k.a. linear algebra'
10 url='https://eigen.tuxfamily.org'
11 license=(GPL3 LGPL2.1 BSD custom:MPL2 custom:MINPACK)
12 makedepends=(cmake freeglut gcc-fortran fftw suitesparse boost)
13 source=(https://gitlab.com/libeigen/eigen/-/archive/$pkgver/$pkgname-$pkgver.tar.gz)
14 sha256sums=('8586084f71f9bde545ee7fa6d00288b264a2b7ac3607b974e54d13e7162c1c72')
17 cmake -B build -S $pkgname-$pkgver \
18 -DCMAKE_INSTALL_PREFIX=/usr
22 DESTDIR="$pkgdir" cmake --install build
24 # install custom licenses
25 install -Dm644 $pkgname-$pkgver/COPYING.* -t "$pkgdir/usr/share/licenses/$pkgname"