archrelease: copy trunk to extra-x86_64
[arch-packages.git] / evolution-ews / repos / extra-x86_64 / PKGBUILD
bloba7e9e3744a7ef3aec5a70d53452a4b747939729f
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
4 pkgname=evolution-ews
5 pkgver=3.48.1
6 pkgrel=1
7 pkgdesc="MS Exchange integration through Exchange Web Services"
8 url="https://wiki.gnome.org/Apps/Evolution/EWS"
9 arch=(x86_64)
10 license=(LGPL2.1)
11 depends=(
12   evolution
13   libmspack
15 makedepends=(
16   cmake
17   git
18   intltool
19   ninja
20   python
21   systemd
23 _commit=4468f359068cbef208657a715f0e1a8814a245e8  # tags/3.48.1^0
24 source=("git+https://gitlab.gnome.org/GNOME/evolution-ews.git#commit=$_commit")
25 b2sums=('SKIP')
27 pkgver() {
28   cd $pkgname
29   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
32 prepare() {
33   cd $pkgname
36 build() {
37   local cmake_options=(
38     -DCMAKE_INSTALL_PREFIX=/usr
39     -DLIBEXEC_INSTALL_DIR=/usr/lib
40     -DSYSCONF_INSTALL_DIR=/etc
41   )
43   cmake -S $pkgname -B build -G Ninja "${cmake_options[@]}"
44   cmake --build build
47 package() {
48   DESTDIR="$pkgdir" cmake --install build
51 # vim:set sw=2 sts=-1 et: