archrelease: copy trunk to extra-x86_64
[arch-packages.git] / farstream / trunk / PKGBUILD
blob83cd4e16bea84963daea1900ebb79c7880fcfae0
1 # Maintainer:
3 pkgname=farstream
4 pkgver=0.2.9
5 pkgrel=3
6 pkgdesc="Farstream (formerly Farsight) - Audio/Video Communications Framework"
7 arch=('x86_64')
8 url="https://www.freedesktop.org/wiki/Software/Farstream"
9 license=('LGPL')
10 depends=('gst-plugins-base-libs' 'libnice')
11 makedepends=('gobject-introspection' 'python' 'gtk-doc')
12 optdepends=('gst-plugins-good' 'gst-plugins-bad')
13 conflicts=('farsight2')
14 replaces=('farsight2')
15 source=(https://freedesktop.org/software/$pkgname/releases/$pkgname/$pkgname-$pkgver.tar.gz{,.asc}
16         farstream-make-4.3.patch)
17 sha256sums=('cb7d112433cf7c2e37a8ec918fb24f0ea5cb293cfa1002488e431de26482f47b'
18             'SKIP'
19             '2e7fe73d43c4b1baa5ba0f191aa54c1abb5f72a2bb801d149e7094f4c2c8d0c2')
20 validpgpkeys=('DB30B086FAF86CE7296FADC51D388E5A4ED9A2BB')  # Olivier CrĂȘte
22 prepare() {
23   cd $pkgname-$pkgver
24   patch -p1 -i ../farstream-make-4.3.patch # Fix build with make 4.3
25   ./autogen.sh
28 build() {
29   cd $pkgname-$pkgver
30   ./configure --prefix=/usr \
31     --enable-gtk-doc \
32     --with-package-name='Arch Linux farstream package' \
33     --with-package-origin='http://archlinux.org'
34   make
37 package() {
38   cd $pkgname-$pkgver
39   make DESTDIR="$pkgdir" install
42 # vim:set ts=2 sw=2 et: