archrelease: copy trunk to extra-x86_64
[arch-packages.git] / folks / trunk / PKGBUILD
blob32947e0b8e54b64e2d4975125cf5b28ba28938a4
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
4 pkgname=folks
5 pkgver=0.15.6
6 pkgrel=1
7 pkgdesc="Library to aggregates people into metacontacts"
8 url="https://wiki.gnome.org/Projects/Folks"
9 arch=(x86_64)
10 license=(LGPL)
11 depends=(
12   evolution-data-server
13   libgee
14   libxml2
16 makedepends=(
17   git
18   gobject-introspection
19   gtk-doc
20   libsysprof-capture
21   meson
22   python-dbusmock
23   vala
25 provides=(
26   libfolks.so
27   libfolks-{dummy,eds}.so
29 options=(!lto)
30 _commit=1ae8ccc3e55bd1b840d9082de1a19e5a6b5ccf83  # tags/0.15.6^0
31 source=("git+https://gitlab.gnome.org/GNOME/folks.git#commit=$_commit")
32 sha256sums=('SKIP')
34 pkgver() {
35   cd folks
36   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
39 prepare() {
40   cd folks
43 build() {
44   local meson_options=(
45     -D b_lto=false  # LTO copies some GType constructors
46     -D docs=true
47     -D profiling=true
48     -D telepathy_backend=false
49   )
51   arch-meson folks build "${meson_options[@]}"
52   meson compile -C build
55 check() {
56   meson test -C build --print-errorlogs -t 4
59 package() {
60   meson install -C build --destdir "$pkgdir"
63 # vim:set sw=2 sts=-1 et: