1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
5 pkgname=(gcr-4 gcr-4-docs)
8 pkgdesc="A library for bits of crypto UI and parsing"
9 url="https://gitlab.gnome.org/GNOME/gcr"
28 _commit=3376d13fd57215a6a75d83edce0b010c7483342a # tags/4.1.0^0
29 source=("git+https://gitlab.gnome.org/GNOME/gcr.git#commit=$_commit")
34 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
43 meson compile -C build
47 # Secure memory tests fail
48 dbus-run-session meson test -C build --print-errorlogs || :
52 optdepends=('gtk4: gcr-viewer-gtk4')
59 meson install -C build --destdir "$pkgdir"
61 mkdir -p doc/usr/share
62 mv {"$pkgdir",doc}/usr/share/doc
65 package_gcr-4-docs() {
66 pkgdesc+=" (documentation)"
72 # vim:set sw=2 sts=-1 et: