archrelease: copy trunk to extra-x86_64
[arch-packages.git] / ghex / repos / extra-x86_64 / PKGBUILD
blobab2b9bde31f995f956c9180780ba3ce6edb3a8e0
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
3 # Contributor: Tobias Kieslich <tobias@justdreams.de>
5 pkgbase=ghex
6 pkgname=(
7   ghex
8   ghex-docs
10 pkgver=44.1
11 pkgrel=1
12 pkgdesc="A simple binary editor for the Gnome desktop"
13 url="https://wiki.gnome.org/Apps/Ghex"
14 arch=(x86_64)
15 license=(GPL)
16 depends=(libadwaita)
17 makedepends=(
18   gi-docgen
19   git
20   gobject-introspection
21   meson
22   yelp-tools
24 _commit=128561d95b1d5088a27d5ad4ebe7bab265437d7a  # tags/44.1^0
25 source=("git+https://gitlab.gnome.org/GNOME/ghex.git#commit=$_commit")
26 b2sums=('SKIP')
28 pkgver() {
29   cd ghex
30   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
33 prepare() {
34   cd ghex
37 build() {
38   arch-meson ghex build -D gtk_doc=true
39   meson compile -C build
42 check() {
43   meson test -C build --print-errorlogs
46 package_ghex() {
47   provides=(libgtkhex-4.so)
48   groups=(gnome-extra)
50   meson install -C build --destdir "$pkgdir"
52   mkdir -p doc/usr/share
53   mv {"$pkgdir",doc}/usr/share/doc
56 package_ghex-docs() {
57   pkgdesc+=" (documentation)"
58   depends=()
60   mv doc/* "$pkgdir"
63 # vim:set sw=2 sts=-1 et: