archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gjs / trunk / PKGBUILD
blob23c602a230c64ab69e0e3002b42c84def2926eb0
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
4 pkgname=gjs
5 pkgver=1.76.0
6 pkgrel=2
7 epoch=2
8 pkgdesc="Javascript Bindings for GNOME"
9 url="https://wiki.gnome.org/Projects/Gjs"
10 arch=(x86_64)
11 license=(GPL)
12 depends=(
13   cairo
14   dconf
15   gobject-introspection-runtime
16   js102
17   libsysprof-capture
18   readline
20 makedepends=(
21   dbus
22   git
23   gobject-introspection
24   meson
26 checkdepends=(
27   gtk3
28   gtk4
29   xorg-server-xvfb
31 provides=(libgjs.so)
32 _commit=ff2e1b2f15cf246eb391a356a0ac0ea09fafc2e6  # tags/1.76.0^0
33 source=("git+https://gitlab.gnome.org/GNOME/gjs.git#commit=$_commit")
34 b2sums=('SKIP')
36 pkgver() {
37   cd gjs
38   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
41 prepare() {
42   cd gjs
44   # https://bugs.archlinux.org/task/78549
45   # https://gitlab.gnome.org/GNOME/gjs/-/issues/472
46   # https://gitlab.gnome.org/GNOME/gjs/-/merge_requests/834
47   git cherry-pick -n 1b49495e762e051d60c7e2efda038de9eea4a214
50 build() {
51   local meson_options=(
52     -D installed_tests=false
53   )
55   CFLAGS="${CFLAGS/-O2/-O3} -fno-semantic-interposition"
56   CXXFLAGS="${CXXFLAGS/-O2/-O3} -fno-semantic-interposition"
57   LDFLAGS+=" -Wl,-Bsymbolic-functions"
59   arch-meson gjs build "${meson_options[@]}"
60   meson compile -C build
63 check() {
64   dbus-run-session xvfb-run -s '-nolisten local' \
65     meson test -C build --print-errorlogs
68 package() {
69   depends+=(libreadline.so)
70   meson install -C build --destdir "$pkgdir"
73 # vim:set sw=2 sts=-1 et: