1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
8 pkgdesc="Javascript Bindings for GNOME"
9 url="https://wiki.gnome.org/Projects/Gjs"
15 gobject-introspection-runtime
32 _commit=ff2e1b2f15cf246eb391a356a0ac0ea09fafc2e6 # tags/1.76.0^0
33 source=("git+https://gitlab.gnome.org/GNOME/gjs.git#commit=$_commit")
38 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
44 # https://bugs.archlinux.org/task/78549
45 # https://gitlab.gnome.org/GNOME/gjs/-/issues/472
46 # https://gitlab.gnome.org/GNOME/gjs/-/merge_requests/834
47 git cherry-pick -n 1b49495e762e051d60c7e2efda038de9eea4a214
52 -D installed_tests=false
55 CFLAGS="${CFLAGS/-O2/-O3} -fno-semantic-interposition"
56 CXXFLAGS="${CXXFLAGS/-O2/-O3} -fno-semantic-interposition"
57 LDFLAGS+=" -Wl,-Bsymbolic-functions"
59 arch-meson gjs build "${meson_options[@]}"
60 meson compile -C build
64 dbus-run-session xvfb-run -s '-nolisten local' \
65 meson test -C build --print-errorlogs
69 depends+=(libreadline.so)
70 meson install -C build --destdir "$pkgdir"
73 # vim:set sw=2 sts=-1 et: