archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gnome-backgrounds / trunk / PKGBUILD
blobf28d2f48662e9e6ac7ba212c72a5a9943061c785
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=gnome-backgrounds
5 pkgver=44.0
6 pkgrel=1
7 pkgdesc="Background images and data for GNOME"
8 url="https://gitlab.gnome.org/GNOME/gnome-backgrounds"
9 arch=(any)
10 license=(CCPL:by-sa)
11 depends=(webp-pixbuf-loader)
12 makedepends=(glib2 meson)
13 groups=(gnome)
14 source=(https://download.gnome.org/sources/$pkgname/${pkgver%%.*}/$pkgname-$pkgver.tar.xz)
15 sha256sums=('4a8393b387135f2a6a424a1a0c3ac94e0742b62b8235a0923c929f51e04be04e')
17 build() {
18   arch-meson $pkgname-$pkgver build
19   meson compile -C build
22 check() {
23   meson test -C build --print-errorlogs
26 package() {
27   meson install -C build --destdir "$pkgdir"
30 # vim:set sw=2 sts=-1 et: