1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
3 # Contributor: Roman Kyrylych <roman@archlinux.org>
5 pkgname=gnome-bluetooth-3.0
8 pkgdesc="GNOME Bluetooth Subsystem"
9 url="https://wiki.gnome.org/Projects/GnomeBluetooth"
12 depends=(gtk4 libadwaita libnotify bluez gsound systemd pulseaudio-bluetooth
14 makedepends=(gobject-introspection gtk-doc docbook-xsl git meson)
15 checkdepends=(python-dbusmock)
16 provides=(libgnome-bluetooth{,-ui}-3.0.so)
18 _commit=8ff1cc5f60b4855c9618d3cef75abf9a0b9c66f8 # master
19 source=("git+https://gitlab.gnome.org/GNOME/gnome-bluetooth.git#commit=$_commit")
24 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
31 git tag -f 42.5 8ff1cc5f60b4855c9618d3cef75abf9a0b9c66f8
35 arch-meson gnome-bluetooth build -D gtk_doc=true
36 meson compile -C build
40 meson test -C build --print-errorlogs
44 meson install -C build --destdir "$pkgdir"
47 # vim:set sw=2 sts=-1 et: