archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gnome-bluetooth-3.0 / trunk / PKGBUILD
blobac8838143df90e75c0db3d99d5badba053f31073
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
3 # Contributor: Roman Kyrylych <roman@archlinux.org>
5 pkgname=gnome-bluetooth-3.0
6 pkgver=42.5
7 pkgrel=1
8 pkgdesc="GNOME Bluetooth Subsystem"
9 url="https://wiki.gnome.org/Projects/GnomeBluetooth"
10 arch=(x86_64)
11 license=(GPL LGPL)
12 depends=(gtk4 libadwaita libnotify bluez gsound systemd pulseaudio-bluetooth
13          upower)
14 makedepends=(gobject-introspection gtk-doc docbook-xsl git meson)
15 checkdepends=(python-dbusmock)
16 provides=(libgnome-bluetooth{,-ui}-3.0.so)
17 _commit=8ff1cc5f60b4855c9618d3cef75abf9a0b9c66f8  # master
18 source=("git+https://gitlab.gnome.org/GNOME/gnome-bluetooth.git#commit=$_commit")
19 sha256sums=('SKIP')
21 pkgver() {
22   cd gnome-bluetooth
23   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
26 prepare() {
27   cd gnome-bluetooth
29   # Fixup missing tag
30   git tag -f 42.5 8ff1cc5f60b4855c9618d3cef75abf9a0b9c66f8
33 build() {
34   arch-meson gnome-bluetooth build -D gtk_doc=true
35   meson compile -C build
38 check() {
39   meson test -C build --print-errorlogs
42 package() {
43   meson install -C build --destdir "$pkgdir"
46 # vim:set sw=2 sts=-1 et: