archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gnome-clocks / trunk / PKGBUILD
blob9b15a2e8860b1575d7e1c7abb074d95890417437
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=gnome-clocks
4 pkgver=44.0
5 pkgrel=1
6 pkgdesc="Clocks applications for GNOME"
7 url="https://wiki.gnome.org/Apps/Clocks"
8 arch=(x86_64)
9 license=(GPL)
10 depends=(
11   geoclue
12   geocode-glib-2
13   gnome-desktop-4
14   gsound
15   gtk4
16   libadwaita
17   libgweather-4
19 makedepends=(
20   git
21   gobject-introspection
22   meson
23   vala
24   yelp-tools
26 groups=(gnome)
27 _commit=220460fde76ef779436dacb07bc3b0589995e608  # tags/44.0^0
28 source=("git+https://gitlab.gnome.org/GNOME/gnome-clocks.git#commit=$_commit")
29 b2sums=('SKIP')
31 pkgver() {
32   cd $pkgname
33   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
36 prepare() {
37   cd $pkgname
40 build() {
41   arch-meson $pkgname build
42   meson compile -C build
45 check() {
46   meson test -C build --print-errorlogs
49 package() {
50   meson install -C build --destdir "$pkgdir"
53 # vim:set sw=2 sts=-1 et: